
 

COMPUTER TRAINING 
MICROSOFT EXCEL 2007 

Macros, Formulas, & Functions 
 

 
Introduction 
 
This handout is designed to familiarize the user with the most common functions in Excel.  
 
Using Formulas 
 
 Formulas and function are mathematical statements used to perform calculations.  
 
• A formula is an instruction made up by the user to perform a specific calculation.  

• All formulas must start with an equal sign and contain cell addresses, numbers, and 
mathematical operators.  

• When preparing a formula it is important to consider the order of mathematical operations. A 
formula that has more than one operation follows an order of precedence.   

The order is as follows from left to right:  
1. Exponentiation  
2. Multiplication 
3. Division 
4. Addition 
5. Subtraction 

 
Note: If a formula has parenthesis, the operation (s) in the parenthesis is performed first. 
Remember to use the math acronym Please Excuse My Dear Aunt Sally to assist with the order 
of operations. 
 
Example:   
Operator Meaning Example Result (if A1=18 & A2 = 2) 

+ Addition =A1+A2 20 

- Subtraction =A1-A2 16 

* Multiplication =A1*A2 36 

/ Division =A1/A2 9 

% Percentage =A1%A2 .18 

^ Exponentiation  =A1^A2 324 
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Exercise 1 
 

1. Create the worksheet listed shown on the next page. The sale tax is approximately is 6% 
entered as .06. 

2. Enter the labels and values in the exact cell locations shown in the spreadsheet then format 
the values as currency. 

3. Enter the formulas, as shown in the shaded cells. Tap the Enter key after each formula. 

4. Copy the formula to the respective cells by using the fill handle and drag downward. 

5. Click inside cell C9 and then click on the down arrow next to the Auto Sum command ‘Σ’ 
located on the Home tab. Choose the Average function from the menu.  

6. Select the cell range G3:G5.  

7. Repeat the prior steps for cell C10, but this time use the Sum function.  

8. Format the cells using the currency format with the dollar sign.  

 
 A B C D E F G 
1 Merchandise  List Price Discount Purchase Price Sales Tax Total  
2        
3 Printer  345 185 =C3-D3 =E3*$C$7 = E3+F3 
4 Computer  985 265    
5 Monitor  395 98    
6        
7 Sales Tax  .06     
8        
9 Average Cost  =AVG(G3:G5)     
10 Grand Total  =SUM(G3:G5)     
        
 
 Exercise 2 
Using the PMT Function 
 
1. Select the cell range A1:C1 and then click the Merge & Center list arrow in the Alignment 

group on the Home tab. Select Merge Cells. Resize the Font if you wish. 

2. Select cell range A3:B3 and then merge the cells. Drag the Fill handle downward to repeat 
the merge process. Stop after cell range A8:B8. 

 
3.     Cell:                    Type 

 A1  Payment Calculator 
 A3  Sticker Price 
 A4  Interest Rate 
 A5  Down Payment 
 A6  Loan Amount 
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 A7  Months 
 A8  Monthly Payment 

 
 
4. Bold cell range A3:A8.  

5. Hold the Ctrl-key down and select cells C3, C5, C6, and C8. Right-click and choose 
Format Cells | Currency | Decimal places 2 and use the $ sign. Select the fourth format 
from the negative numbers box to display the debit format.  

6. Select cell C4. Right click and then choose Percentage | Decimal places 2. Click OK and 
then press the Enter key three times. Select cell C7. Right-click and choose Format Cells | 
Number and change the decimal places to 0. 

7. In cell C6 type =C3-C5. Press Enter.  

8. Select cell C8 and click on the Insert Function button on the Formula Bar. This will open 
the Function dialog box. 

9. Under the heading 
"Select a function:" 
select the PMT function. 
Click OK. 

10. Left click and hold down 
the mouse button on the 
top part of the dialog box 
to move the Function 
Argument box to view 
the cells in your work 
area.  

11. Click inside the 
Argument box "Rate" 
and then click cell C4. Press the forward slash / (division) key and then enter 12. The interest 
rate is computed annual. 

12. Click inside the Argument box Nper (number of payments) and then click cell C7 for the 
number of payments. Click inside the next Argument box Pv. (this stands for the Present 
value of the loan amount). Type a negative sign (-), then click cell C6. The negative sign 
before C6 allows us to display a positive number. This play an important role in the next 
exercise.  

You have just used the function box to create a spreadsheet that calculates what your payments 
would be if you were to purchase a vehicle.  
 
• Enter amounts for the sticker price, down payment, and interest rate.  
• Change the number of payments and the amount will change.  
• Change the interest rate and amount will increase or decrease.  
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This formula changes with the data entered.  
 
Using the If Statement 
 
1. In cell A16, type Purchase and then 

merge and bold the cell range 
A16:B16.  

2. Click inside cell C16 and then the 
Insert Function button on the 
formula bar. Select the IF Function.  

3. In the argument box "Logical Test" 
enter cell reference C8 type <=250. 

4. In the Value_if_true box type Deal 
and then press the Tab key. 
 
In the Value_if_false box type No Deal. Click OK. 
 

The decision to purchase will be reflected by one or all of the following factors, (1) amount 
borrowed, (2) interest rate, (3) down payment, or (4) term of loan. 
 
 
Using Goal Seek 
 
1. Click the tab "Data", and then the "What If Analysis 

list arrow in the Data Tools group. Select Goal Seek.  
2. Collapse the "Set cell:" dialog box to select the cell 

value to change. For this example choose Monthly 
Payment cell C8.  

3. Enter a number (goal) in the box "To value:" and then 
press the tab key. 

4. Collapse the "By changing cell:" dialog box and then 
click in cell C5, Down Payment. Click OK. Cell C5 now reflects the down payment required 
to attain the desired goal. 
  
 

Exercise 3 
Calculating the Total Interest Paid & Total Cost of the Loan 
 

1. Select cell range A11:B11. Click the Merge & Center list arrow in the Alignment group and 
select Merge Cells. Use the Fill handle to repeat the merge process to the range below. 

2. In cells A11 type Total Interest and in A12 type Total Cost.  
3. Select cells A11 and A12. Right click the selected cells and choose Format Cells | Currency 

| Decimal places 2 and use the $ sign. 



5 

4. In cell A11 type=C7*C8-C6. Press the tab key.  
           A12 type =C7*C8+C5. Press the tab key and then bold the cell range A11:A12. 
 

 
Creating a Data Table to Analyze a Worksheet 
 
By creating a data table you can compare the answers for several different "What if" values. 

1. Copy and paste cell range A1:C8 in Sheet 3. 

2. Select and then Merge & Center cell range E1:H1. Type Table Display of Varying Interest 
Rates in the new merged cell.  

3. Enter the following column labels starting in cell E2 to H2.  
Cell#  Labels 
E2   Interest Rate 
F2   Monthly Payment 
G2   Total Interest 
H2   Total Cost 

4. Select the cell range E2:H2. Click the Center button in the Alignment group on the Home 
tab. Next, click the Format list arrow and choose "AutoFit Column Width".  

5. Click in cell E4 and enter .02 as the first number. Then enter .0225 in cell E5. Select and 
format both cells as percentage with two decimal places. 

6. Drag the fill handle to cell E14 and release. Excel incremented each cell by 0.25%. 
7. Click in cell F3. Type =C8, tab or press the right arrow key.  

Click in cell G3. Type =C10, tab or press the right arrow key.  
Click in cell H3. Type =C11, press Enter. 

8. Select the range E3:H14. Click the What If Analysis list arrow in the Data Tools group on 
the Data tab. Click the button Data Table and then click in the "Column input cell" box and 
then either type C4 or click in cell C4. Click OK.  

9. Excel calculates the results of the three formulas in row 3 for each interest rate in column D 
and immediately fills corresponding values in the data table. 

10. Select the cell range F4:H14 and then format the cells as a number with to decimal places. 
Click the box to Use a 1000 Separator (,). 
 

Note: At your discretion you may apply borders around the Payment Calculator and the Data 
Table. 
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Scenario Summary 
 
1. Click the What If Analysis list arrow in the Data 

Tools group on the Data tab and then the command 
Scenario Manager.  

2. Click the Add button and provide a scenario name. 
Collapse the dialog box "Changing Cells" to select 
the cells that you would like to change and compare 
against other data. To select non-adjacent cells press 
the Ctrl key and then click on the respective cells.  
 

3. For example: To change the Interest Rate and the 
Loans Term (Months).   

… Hold the Ctrl key down and then click on cells C4 and C7. Click OK. The Scenario 
Values dialog box appears. 

… Enter the new values in the cells referenced by inputting the new Interest Rate and 
Loan Term.  

… Click the Add button to add another scenario and provide another name to compare 
the results in either a pivot table or summary sheet. Click OK and enter the new 
values. 
 

4. To display the changes in the current spreadsheet 
remove the checkmark from "Prevent Changes". 
Click OK and then Show to see the changes.  

 
To display the changes summarized in a new 
worksheet select "Summary". When the Scenario 
Summary dialog box appears, hold down the Ctrl 
key and select cells C8, C10, and C11 and then 
click OK.  
 
The scenario worksheet displays as shown below. 
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Exercise 4 
Sorting Custom Lists 
 

1. Insert a new spreadsheet and name it Custom Lists. Enter the data below. 

Cell Entry 
A1  Date 
B1  Department 
C1  Purchase 
D1  Cost 

2. Starting in cell A2 enter the current date and then use the tab key to enter the data below. The 
dates may be sequential or incremented and costs not specific to those listed. 
 

Date Department Purchase Cost 

4/2/2010 A Printing  $44.00 

4/3/2010 B Software $124.00 

4/4/2010 C Computers $3,200.00 

4/5/2010 C Software $500.00 

4/6/2010 C Printing $79.00 

4/7/2010 A Hardware $300.00 

4/8/2010 A Printing $1,200.00 

4/9/2010 C Hardware $55.00 

4/10/2010 B Hardware $2,400.00 

4/11/2010 B Printing $150.00 

4/12/2010 A Software $300.00 

4/13/2010 B Printing  $79.00 

 

3. Select the cell range A1:D1 and then click on the Microsoft Office Button. 

4. At the bottom of list click Excel Options. Choose the category Popular under the label "Top 
options for working in Excel", click Edit Custom Lists.  

5.  In the Custom Lists dialog box, verify that the cell reference displayed in the Import list 
from cells box is listed and correct. Click Import and then OK twice. 
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6. Click in any cell within your data. Click the Sort & Filter list arrow in the Editing group on 
the Home tab. Select the command Custom Lists and when the Sort dialog box opens 
choose to Sort by: Department under Column. Select Custom Lists under Order.  

 

 
 
 
 
 

7. Select the list Date, Department, Purchase and Cost and then click OK. Click the Options 
button above and set the Orientation to "Sort top to bottom". Click OK twice. 

8. Click the tab Data and then inside one of the list's headers. In the group 
Outline, select the command Subtotals. Change the following - At each 
change in: select Department, Use Function: Sum, and Add subtotal to: 
check the box Cost.  

Note: you need to check the boxes Replace current subtotals and Summary 
below data. Click OK. 
 

9. Data should resemble the graphic on the right. 
 

Note: Collapsing the minus buttons on the left side 
hides the detail displayed such as Dates and 
Purchases. 
 
 
 
 
Recording a Macro 
 
Macro 1 
Auto formatting a worksheet  
 
Before beginning note that in order to save a macro in Excel 2007 the workbook must be saved 
as an Excel Macro-Enable Workbook. In addition you will need to add the Developer tab to the 
Ribbon.  
 
How to: 
Click on the Office button and then the Excel Options button. Choose the category Popular, then 
check the box "Show Developer tab in the Ribbon". 

1. Insert a New Worksheet into the Workbook and rename the sheet Macro1, then copy and 
paste the example data from Sheet 4 into the sheet named Macro1.  



9 

How to: Click the rectangle between column A1 and row 1 to select the whole worksheet. 
Click on the Copy button and then paste the data into the sheet Macro1. 

2. Click on the tab Developer and then Record New Macro. You can either assign a name or 
use the default. Choose This Workbook from the drop down menu in the dialog box. A 
description is optional. 

3. Select the range A1:G1 and then click the Merge & Center list arrow in the Alignment group 
and select Merge & Center on the Home tab. Change the font to size 14 Bold then repeat 
only the Merge & Center for cell range A2:G2. 

4. Select and Bold cell range A5:G5. 

5. Select cell range C6:G8 and then right click | Format cells. Select the tab Number | 
Category | Number. Check the box Decimal places (2) and Use 1000 Separator (,). 

6. Select the range C9:G9. Right click | Format cells | Accounting | (show) $ sign, 2 decimal 
places. 

7. Select and Bold cell A12.  

8. Select and Bold cell C12 and right click and choose Format cells |Accounting | show $ sign 
and 2 decimal places. Click the Stop Macro button and save the worksheet. 

9. Select the entire worksheet as we did in the beginning see Step 1. On the Home tab click the 
button Clear, then Clear Formats. When the formatting is removed return to the Developer 
tab. Click the command button Macros and then run the assigned macro. 

 
 
Macro 2 
Assign a macro to enter your name and the current date    

1. Click the tab Developer and then Record New Macro. You can either assign a name or use 
the default. Choose This Workbook from the drop down menu in the dialog box. A 
description is optional. 

2. Right-click cell A20 and choose the command Format cells. Select Date as the category and 
then the Type: "*Wednesday, March 14, 2001" as displayed. 

3. Next, type =TODAY() in the newly formatted cell. Press Enter. 

4. In cell A21, type your name and then click the Stop Macro button and save the worksheet. 
On the Home tab click the command button Clear, then Clear Formats. Click in any cell 
then run the assigned Marco. 
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Macro 3 
Deleting Blank Rows 

1. Enter some date in a work sheet leaving blank rows between the 
data. Use may use the data in Sheet5 or type your own. 

2. Click the tab Developer and then the command button Record 
New Macro. You can either assign a name or use the default. 
Choose This Workbook from the drop down menu in the dialog 
box. A description is optional. 

3. Click on the tab Home. Click the Find & Select list arrow in the 
Editing group on the Home Tab. Select the command Go To 
Special and then select the option Blanks. Click OK to select the 
blank rows.  

4. Click the Delete list arrow in the Editing group on the Home tab. Select the command Delete 
Rows to delete all blank rows.  

Please note that any merged cells are also deleted.  


